Installation des VMware tools de vmWare server 2.0 ou vSphere 5 sur Debian Linux 7 Wheezy

Une fois n’est pas coutume un petit billet informatique. Bien que VMWare server 2.0 ne soit plus forcément un produit d’actualité, vous pourriez avoir besoin d’installer une debian 7 noyau version 3.2 dessus, avec les VMWare tools actifs de préférence. Le problème c’est que lors de l’installation de ces outils le script vmware-config-tools.pl va échouer à compiler les modules nécessaires.

J’ai trouvé ici en partie les astuces nécessaires que voici adaptées à une version 3.2.0-4-amd64.

Voici les instructions à exécuter,après avoir bien sûr installé les paquets essentiels : 

apt-get install  linux-headers-`uname -r` make gcc build-essential
#!/bin/bash
echo "Creating some simlinks for the newer kernels..."
ln -s /usr/src/linux-headers-`uname -r`/include/generated/autoconf.h /usr/src/linux-headers-`uname -r`/include/linux/autoconf.h
ln -s /usr/src/linux-headers-`uname -r`/include/generated/utsrelease.h /usr/src/linux-headers-`uname -r`/include/linux/utsrelease.h
echo "Exporting CC..."
export CC=/usr/bin/gcc-4.6
echo "Starting VMware Server original config script..."
/usr/bin/vmware-config.pl
exit 0

Ok, donc ça en fait c’est la méthode compliquée, il y a plus simple, juste faire :

apt-get install open-vm-tools

http://open-vm-tools.sourceforge.net/about.php

Ce paquet simplifie la tâche, j’ai pu le tester avec succès sous vmWare 2.0 et vSphere 5.0.


Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *